TinyMCE requires standards mode エラーの原因

HTML&CSSプラグイン

TinyMCE のバージョンを 4 系から 5 にアップデートしたら、エラーが出た。

Failed to initialize the editor as the document is not in standards mode. TinyMCE requires standards mode.

原因
DOCTYPE を、 HTML 4.01 で宣言していたから。。。
バージョン 5 からは、 HTML 5 の DOCTYPE 宣言でないといけない。

You are probably using an old DOCTYPE as of TinyMCE 4 a proper HTML5 doctype is required. All web developers should use a standard rendering mode on their web pages. Use a HTML5 doctype like to properly render the page and the TinyMCE UI.
Q: Why do buttons/select boxes have the incorrect size?

解決法
こう書く。

<!DOCTYPE html>

Posted by Agopeanuts